summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ddfa3a2b72..089dd17201 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4162,6 +4162,35 @@ your host privately.")
 inputs and applications using PipeWire.")
     (license license:gpl2+)))
 
+(define-public obs-source-copy
+  (package
+    (name "obs-source-copy")
+    (version "0.2.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/exeldro/obs-source-copy")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1l3ls3j57yh03vkwiah6yj1xnnmq7q2ngjjn1k4h1sqqk0dxn86j"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f ;no tests
+      #:configure-flags
+      #~(list (string-append "-DLIBOBS_INCLUDE_DIR="
+                             #$(this-package-input "obs") "/lib")
+              "-DBUILD_OUT_OF_TREE=On"
+              "-Wno-dev")))
+    (inputs (list obs qtbase-5))
+    (home-page "https://github.com/exeldro/obs-source-copy")
+    (synopsis "OBS plugin for copy and paste scenes, sources and filters")
+    (description "This package provides an OBS plugin for copy and paste
+scenes, sources and filters.")
+    (license license:gpl2)))
+
 (define-public obs-source-record
   (package
     (name "obs-source-record")