summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 471f97b111..98b7c41d9f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -104,7 +104,7 @@
     (inputs
      `(("ncurses" ,ncurses)))
     (arguments
-     '(#:phases
+     `(#:phases
        (modify-phases %standard-phases
          (replace 'configure
                   (lambda* (#:key build inputs outputs #:allow-other-keys)
@@ -116,6 +116,12 @@
                       (zero? (system* "./configure"
                                       (string-append "--prefix=" out)
                                       (string-append "--build=" build)
+                                      ;; The ancient config.guess is unable to
+                                      ;; guess the host triplet on mips64el.
+                                      ,@(if (string=? "mips64el-linux"
+                                                      (%current-system))
+                                            '("--host=mips64el-unknown-linux-gnu")
+                                            '())
                                       (string-append "--with-ncurses="
                                                      ncurses)))))))))
     (home-page "http://aa-project.sourceforge.net/aalib/")