summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5e1e9b852c..6a98f0a5a4 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -693,6 +693,13 @@ are detected, the user is notified.")))
        #:configure-flags '("-DPREFER_LUA:BOOL=YES")
        #:phases
        (modify-phases %standard-phases
+         ;; TODO: remove 'patch-tic on update
+         ;; see: https://github.com/neovim/neovim/issues/9687
+         (add-after 'unpack 'patch-tic
+           (lambda _
+             (substitute* "src/nvim/tui/tui.c"
+               (("value != NULL") "value != NULL && value != (char *)-1"))
+             #t))
          (add-after 'unpack 'set-lua-paths
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((lua-version "5.2")