summary refs log tree commit diff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 2c0b2f15c9..5bf5a62481 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -319,13 +319,14 @@ endpoints.")
       #~(modify-phases %standard-phases
           (add-before 'bootstrap 'move-configure
             ;; Don't execute configure script in bootstrap.
-            (lambda* (#:key inputs #:allow-other-keys)
+            (lambda _
               (substitute* "autogen.sh"
                 (("./configure") ""))))
           (add-before 'configure 'fix-configure
-            (lambda* (#:key inputs #:allow-other-keys)
+            (lambda* (#:key inputs native-inputs #:allow-other-keys)
               (substitute* "configure"
-                (("/bin/sh") (search-input-file inputs "/bin/sh"))))))
+                (("/bin/sh")
+                 (search-input-file (or native-inputs inputs) "/bin/sh"))))))
       #:tests? #f))                     ;there is no check target
     (native-inputs
      (list autoconf automake bash-minimal pkg-config))