summary refs log tree commit diff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm140
1 files changed, 68 insertions, 72 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 478de6a444..12b1f93015 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -102,7 +104,7 @@ and for the GLSL.std.450 extended instruction set.
                                                (assoc-ref %build-inputs
                                                           "spirv-headers")))))
      (inputs `(("spirv-headers" ,spirv-headers)))
-     (native-inputs `(("pkg-config", pkg-config)
+     (native-inputs `(("pkg-config" ,pkg-config)
                       ("python" ,python)))
      (home-page "https://github.com/KhronosGroup/SPIRV-Tools")
      (synopsis "API and commands for processing SPIR-V modules")
@@ -189,7 +191,7 @@ interpretation of the specifications for these languages.")
               ("mesa" ,mesa)
               ("spirv-tools" ,spirv-tools)
               ("wayland" ,wayland)))
-    (native-inputs `(("pkg-config", pkg-config)
+    (native-inputs `(("pkg-config" ,pkg-config)
                      ("python" ,python)))
     (home-page
      "https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers")
@@ -210,74 +212,68 @@ and the ICD.")
   (let ((commit "773ec22d49f40b7161820f29d953be4a7e40190d")
         (revision "1"))
     (package
-     (name "shaderc")
-     (version (string-append "0.0-" revision "." (string-take commit 9)))
-     (source
-      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/google/shaderc")
-             (commit commit)))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0b41inb1czxv3mciip0lfdxv19ccx2ys31fivfywjn2q8va1gd1f"))))
-     (build-system meson-build-system)
-     (arguments
-      `(#:tests? #f ;; Tests don't work yet.
-        #:phases
-        (modify-phases %standard-phases
-          (replace 'configure
-                   (lambda* (#:key outputs #:allow-other-keys)
-                     (let ((out (assoc-ref outputs "out")))
-                     ;; Remove various lines and touch build-version.inc or
-                     ;; configuring won't work.
-                     (invoke "touch" "glslc/src/build-version.inc")
-                     (substitute* "CMakeLists.txt" (("..PYTHON_EXE..*") ""))
-                     (substitute* "CMakeLists.txt"
-                                  ((".*update_build_version.py..*") ""))
-                     (substitute* "CMakeLists.txt"
-                                  ((".*add_custom_target.build-version.*") ""))
-                     (substitute* "CMakeLists.txt"
-                                  ((".*spirv-tools_SOURCE_DIR.*glslang_SOURCE_DIR.*")
-                                   ""))
-                     (substitute* "CMakeLists.txt"
-                                  ((".*Update build-version.inc.*") ""))
-                     (substitute* "CMakeLists.txt" ((".*--check.*") ""))
-                     (substitute* "glslc/src/main.cc" ((".*build-version.inc.*")
-                                                       "\"1\""))
-                     (invoke "cmake" "-GNinja" "-DCMAKE_BUILD_TYPE=Release"
-                                     "-DSHADERC_SKIP_TESTS=ON"
-                                     "-DCMAKE_INSTALL_LIBDIR=lib"
-                                     (string-append "-DCMAKE_INSTALL_PREFIX="
-                                                    out)))))
-          (add-after 'unpack 'unpack-sources
-                     (lambda* (#:key inputs #:allow-other-keys)
-                       (let ((spirv-tools-source (assoc-ref %build-inputs
-                                                            "spirv-tools-source"))
-                             (spirv-headers-source (assoc-ref %build-inputs
-                                                              "spirv-headers-source"))
-                             (glslang-source (assoc-ref %build-inputs
-                                                        "glslang-source")))
-                         (mkdir-p "third-party/spirv-tools")
-                         (copy-recursively spirv-tools-source
-                                           "third_party/spirv-tools")
-                         (mkdir-p "third-party/spirv-tools/external/spirv-headers")
-                         (copy-recursively spirv-headers-source
-                                           (string-append "third_party/spirv-tools"
-                                                          "/external/spirv-headers"))
-                         (mkdir-p "third-party/glslang")
-                         (copy-recursively glslang-source
-                                           "third_party/glslang")
-                         #t))))))
-     (inputs `(("python" ,python)))
-     (native-inputs `(("cmake" ,cmake)
-                      ("glslang-source", (package-source glslang))
-                      ("pkg-config", pkg-config)
-                      ("spirv-headers-source", (package-source spirv-headers))
-                      ("spirv-tools-source", (package-source spirv-tools))))
-     (home-page "https://github.com/google/shaderc")
-     (synopsis "Tools for shader compilation")
-     (description "Shaderc is a collection of tools, libraries and tests for
+      (name "shaderc")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/google/shaderc")
+               (commit commit)))
+         (file-name (string-append name "-" version ".tar.gz"))
+         (sha256
+          (base32
+           "0b41inb1czxv3mciip0lfdxv19ccx2ys31fivfywjn2q8va1gd1f"))))
+      (build-system meson-build-system)
+      (arguments
+       `(#:tests? #f                    ; tests don't work yet.
+         #:phases
+         (modify-phases %standard-phases
+           (replace 'configure
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 ;; Remove various lines and touch build-version.inc or
+                 ;; configuring won't work.
+                 (invoke "touch" "glslc/src/build-version.inc")
+                 (substitute* "CMakeLists.txt" (("..PYTHON_EXE..*") ""))
+                 (substitute* "CMakeLists.txt"
+                   ((".*update_build_version.py..*") ""))
+                 (substitute* "CMakeLists.txt"
+                   ((".*add_custom_target.build-version.*") ""))
+                 (substitute* "CMakeLists.txt"
+                   ((".*spirv-tools_SOURCE_DIR.*glslang_SOURCE_DIR.*")
+                    ""))
+                 (substitute* "CMakeLists.txt"
+                   ((".*Update build-version.inc.*") ""))
+                 (substitute* "CMakeLists.txt" ((".*--check.*") ""))
+                 (substitute* "glslc/src/main.cc" ((".*build-version.inc.*")
+                                                   "\"1\""))
+                 (invoke "cmake" "-GNinja" "-DCMAKE_BUILD_TYPE=Release"
+                         "-DSHADERC_SKIP_TESTS=ON"
+                         "-DCMAKE_INSTALL_LIBDIR=lib"
+                         (string-append "-DCMAKE_INSTALL_PREFIX="
+                                        out)))))
+           (add-after 'unpack 'unpack-sources
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((spirv-tools-source (assoc-ref inputs "spirv-tools-source"))
+                     (spirv-headers-source (assoc-ref inputs "spirv-headers-source"))
+                     (glslang-source (assoc-ref inputs "glslang-source")))
+                 (copy-recursively spirv-tools-source "third_party/spirv-tools")
+                 (copy-recursively spirv-headers-source
+                                   (string-append "third_party/spirv-tools"
+                                                  "/external/spirv-headers"))
+                 (copy-recursively glslang-source "third_party/glslang")
+                 #t))))))
+      (inputs
+       `(("python" ,python)))
+      (native-inputs
+       `(("cmake" ,cmake)
+         ("glslang-source" ,(package-source glslang))
+         ("pkg-config" ,pkg-config)
+         ("spirv-headers-source" ,(package-source spirv-headers))
+         ("spirv-tools-source" ,(package-source spirv-tools))))
+      (home-page "https://github.com/google/shaderc")
+      (synopsis "Tools for shader compilation")
+      (description "Shaderc is a collection of tools, libraries, and tests for
 shader compilation.")
-     (license license:asl2.0))))
+      (license license:asl2.0))))