summary refs log tree commit diff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm148
1 files changed, 147 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 2c2767dbbc..6caa486b84 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -6,6 +6,8 @@
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +37,7 @@
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libidn)
+  #:use-module (gnu packages lisp)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages ncurses)
@@ -48,9 +51,11 @@
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages xorg)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
-  #:use-module (guix build-system python))
+  #:use-module (guix build-system python)
+  #:use-module (guix build-system asdf))
 
 (define-public dillo
   (package
@@ -320,3 +325,144 @@ access.")
     (description "qutebrowser is a keyboard-focused browser with a minimal
 GUI.  It is based on PyQt5 and QtWebKit.")
     (license license:gpl3+)))
+
+(define-public vimb
+  (package
+    (name "vimb")
+    (version "3.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fanglingsu/vimb/")
+             (commit version)))
+       (sha256
+        (base32
+         "1qg18z2gnsli9qgrqfhqfrsi6g9mcgr90w8yab28nxrq4aha6brf"))
+       (file-name (git-file-name name version))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     '(#:tests? #f ; no tests
+       #:make-flags (list "CC=gcc"
+                          "DESTDIR="
+                          (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs
+     `(("glib-networking" ,glib-networking)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+       ("webkitgtk" ,webkitgtk)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://fanglingsu.github.io/vimb/")
+    (synopsis "Fast and lightweight Vim-like web browser")
+    (description "Vimb is a fast and lightweight vim like web browser based on
+the webkit web browser engine and the GTK toolkit.  Vimb is modal like the great
+vim editor and also easily configurable during runtime.  Vimb is mostly keyboard
+driven and does not detract you from your daily work.")
+    (license license:gpl3+)))
+
+(define-public next-gtk-webkit
+  (package
+    (name "next-gtk-webkit")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://source.atlas.engineer/public/next")
+             (commit version)))
+       (sha256
+        (base32
+         "00xi01r6gxlrv7xc2dhf4da30y0vng1snbdmc8d829qyn0chl55q"))
+       (file-name (git-file-name "next" version))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags (list "gtk-webkit"
+                          "CC=gcc"
+                          (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'install
+           (lambda* (#:key (make-flags '()) #:allow-other-keys)
+             (apply invoke "make" "install-gtk-webkit" make-flags))))))
+    (inputs
+     `(("glib-networking" ,glib-networking)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+       ("webkitgtk" ,webkitgtk)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://next.atlas.engineer")
+    (synopsis "Infinitely extensible web-browser (user interface only)")
+    (description "Next is a keyboard-oriented, extensible web-browser
+inspired by Emacs and designed for power users.  The application has familiar
+key-bindings, is fully configurable and extensible in Lisp, and has powerful
+features for productive professionals.")
+    (license license:bsd-3)))
+
+(define-public sbcl-next
+  (package
+    (inherit next-gtk-webkit)
+    (name "sbcl-next")
+    (build-system asdf-build-system/sbcl)
+    (outputs '("out" "lib"))
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'patch-platform-port-path
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "source/ports/gtk-webkit.lisp"
+                        (("\"next-gtk-webkit\"")
+                         (string-append "\"" (assoc-ref inputs "next-gtk-webkit")
+                                        "/bin/next-gtk-webkit\"")))))
+                  (add-before 'cleanup 'move-bundle
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (define lib (assoc-ref outputs "lib"))
+                      (define actual-fasl (string-append
+                                           lib
+                                           "/lib/sbcl/next.fasl"))
+                      (define expected-fasl (string-append
+                                             lib
+                                             "/lib/sbcl/next--system.fasl"))
+                      (copy-file actual-fasl expected-fasl)
+                      #t))
+                  (add-after 'create-symlinks 'build-program
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (build-program
+                       (string-append (assoc-ref outputs "out") "/bin/next")
+                       outputs
+                       #:entry-program '((next:start-with-port) 0))))
+                  (add-before 'build 'install-assets
+                    ;; Since the ASDF build system generates a new .asd with a
+                    ;; possibly suffixed and thus illegal version number, assets
+                    ;; should not be installed after the 'build phase or else
+                    ;; the illegal version will result in NIL in the .desktop
+                    ;; file.
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (with-output-to-file "version"
+                        (lambda _
+                          (format #t "~a" ,(package-version next-gtk-webkit))))
+                      (invoke "make" "install-assets"
+                              (string-append "PREFIX="
+                                             (assoc-ref outputs "out"))))))))
+    (inputs
+     `(("next-gtk-webkit" ,next-gtk-webkit)
+       ;; Lisp libraries:
+       ("trivial-features" ,sbcl-trivial-features)
+       ("alexandria" ,sbcl-alexandria)
+       ("cl-strings" ,sbcl-cl-strings)
+       ("cl-string-match" ,sbcl-cl-string-match)
+       ("puri" ,sbcl-puri)
+       ("sqlite" ,sbcl-cl-sqlite)
+       ("parenscript" ,sbcl-parenscript)
+       ("cl-json" ,sbcl-cl-json)
+       ("swank" ,sbcl-slime-swank)
+       ("cl-markup" ,sbcl-cl-markup)
+       ("cl-css" ,sbcl-cl-css)
+       ("bordeaux-threads" ,sbcl-bordeaux-threads)
+       ("s-xml-rpc" ,sbcl-s-xml-rpc)
+       ("unix-opts" ,sbcl-unix-opts)))
+    (synopsis "Infinitely extensible web-browser (with Lisp development files)")))