summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e2669dfb1a..fd6bfbab22 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5154,7 +5154,7 @@ into your tests.  It automatically starts up a HTTP server in a separate thread
 (define-public http-parser
   (package
     (name "http-parser")
-    (version "2.9.1")
+    (version "2.9.2")
     (home-page "https://github.com/nodejs/http-parser")
     (source (origin
               (method git-fetch)
@@ -5163,16 +5163,7 @@ into your tests.  It automatically starts up a HTTP server in a separate thread
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  ;; There are signedness errors that trigger on 32-bit
-                  ;; platforms that trigger, and '-Werror' leads to build
-                  ;; failures.
-                  (substitute* "Makefile"
-                    (("-Werror") ""))
-                  #t))))
+                "1qs6x3n2nrcj1wiik5pg5i16inykf7rcfdfdy7rwyzf40pvdl3c2"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"