summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3ddecb15c4..8df302d240 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -10,7 +10,7 @@
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
 ;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
@@ -8058,28 +8058,25 @@ tools:
     (license license:gpl3+)))
 
 (define-public uriparser
-  (let ((commit "25dddb16cf044a7df27884e7ad3911baaaca3d7c")
-        (revision "1"))
-    (package
-      (name "uriparser")
-      (version (git-version "0.9.4" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/uriparser/uriparser")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1ffzia679axcsccx2fxjpxhb0i5xc42zxn446x6c1170w6v69qf6"))))
-      (build-system cmake-build-system)
-      (native-inputs (list googletest doxygen graphviz))
-      (synopsis "Strictly RFC 3986 compliant URI parsing and handling library")
-      (description "uriparser is a strictly RFC 3986 compliant URI parsing and
+  (package
+    (name "uriparser")
+    (version "0.9.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/uriparser/uriparser"
+                                  "/releases/download/uriparser-"
+                                  version "/uriparser-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0i7nxgy36i8v81r213sbvmpxxq9qb4rhii9qbvl1k32jd1ka1252"))))
+    (build-system cmake-build-system)
+    (native-inputs (list googletest doxygen graphviz))
+    (synopsis "Strictly RFC 3986 compliant URI parsing and handling library")
+    (description "uriparser is a strictly RFC 3986 compliant URI parsing and
 handling library written in C89 (\"ANSI C\").  uriparser is fast and supports
 Unicode.")
-      (home-page "https://uriparser.github.io/")
-      (license license:bsd-3))))
+    (home-page "https://uriparser.github.io/")
+    (license license:bsd-3)))
 
 (define-public quark
   ;; No releases yet