summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6d8054da1b..b4c0785180 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1383,7 +1383,7 @@ unavailable.")
                             "CC=gcc"))
        ;; No 'check' target.
        #:tests? #f))
-    (home-page "http://www.pps.univ-paris-diderot.fr/~jch/software/polipo/")
+    (home-page "https://www.pps.univ-paris-diderot.fr/~jch/software/polipo/")
     (synopsis "Small caching web proxy")
     (description
      "Polipo is a small caching web proxy (web cache, HTTP proxy, and proxy
@@ -1956,15 +1956,14 @@ instance of a component on each request.")
 (define-public perl-catalyst-devel
   (package
     (name "perl-catalyst-devel")
-    (version "1.39")
+    (version "1.40")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://cpan/authors/id/I/IL/ILMARI/"
+       (uri (string-append "mirror://cpan/authors/id/J/JJ/JJNAPIORK/"
                            "Catalyst-Devel-" version ".tar.gz"))
        (sha256
-        (base32
-         "12m50bbkggjmpxihv3wnvr0g2qng0zwhlzi5ygppjz8wh2x73qxw"))))
+        (base32 "1fqnw6cizpxnfr87rpid8w1wpi1p1lxg6imfjpixqn7s055hcpwc"))))
     (build-system perl-build-system)
     (native-inputs
      `(("perl-test-fatal" ,perl-test-fatal)))
@@ -4392,8 +4391,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
   (package-with-python2 python-feedparser))
 
 (define-public guix-data-service
-  (let ((commit "bf25a8db0278b49ef2149c69ef5d6dd2201fd413")
-        (revision "17"))
+  (let ((commit "18eb9dfdcb3174bfd4bab5b9089acffa13aa1214")
+        (revision "18"))
     (package
       (name "guix-data-service")
       (version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4405,7 +4404,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0s6faybczdn10zwrkn22nfq5lvf538513hbmjfaqlkhfmwc4s1qd"))))
+                  "0lb78cqzqaz0r4sspg272w2a3yhzhqah30j0kxf0z182b0qpmp37"))))
       (build-system gnu-build-system)
       (arguments
        '(#:modules ((guix build utils)
@@ -4454,15 +4453,15 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
                  #t)))
            (delete 'strip))))           ; As the .go files aren't compatible
       (inputs
-       `(("guix" ,guix)
-         ("guile-fibers" ,guile-fibers)
-         ("guile-json" ,guile-json-3)
-         ("guile-email" ,guile-email)
-         ("guile-squee" ,guile-squee)
+       `(("guix" ,guile3.0-guix)
+         ("guile-fibers" ,guile3.0-fibers)
+         ("guile-json" ,guile3.0-json)
+         ("guile-email" ,guile3.0-email)
+         ("guile-squee" ,guile3.0-squee)
          ("postgresql" ,postgresql)
          ("sqitch" ,sqitch)))
       (native-inputs
-       `(("guile" ,guile-2.2)
+       `(("guile" ,guile-3.0)
          ("autoconf" ,autoconf)
          ("automake" ,automake)
          ("ephemeralpg" ,ephemeralpg)
@@ -4606,7 +4605,7 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
        ;;("bundler" ,bundler)
        ("valgrind" ,valgrind)))
     (build-system gnu-build-system)
-    (home-page "http://stedolan.github.io/jq/")
+    (home-page "https://stedolan.github.io/jq/")
     (synopsis "Command-line JSON processor")
     (description "jq is like sed for JSON data – you can use it to slice and
 filter and map and transform structured data with the same ease that sed, awk,