summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f291768e12..0c0e159f98 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -551,6 +551,16 @@ This is modified version, specifically intended for use with the NGinx
 documentation.")
       (license license:bsd-2))))
 
+(define nginx-socket-cloexec
+  (package
+    (inherit nginx)
+    (name "nginx-socket-cloexec") ;required for lua-resty-shell
+    (source
+     (origin
+       (inherit (package-source nginx))
+       (patches (append (search-patches "nginx-socket-cloexec.patch")
+                        (origin-patches (package-source nginx))))))))
+
 (define-public lighttpd
   (package
     (name "lighttpd")