summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6e89c3a406..7b0bb915ca 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -439,7 +439,15 @@ APIs.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests included
-       #:make-flags (list "CC=gcc")))
+       #:make-flags (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-CFLAGS
+           ;; Remove broken options unconditionally added to CFLAGS.
+           (lambda _
+             (substitute* "configure.ac"
+               ((" -Werror") ""))
+             #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)