summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 396c5f2474..e77bad76d6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -559,7 +559,10 @@ from streaming URLs.  It is a command-line wrapper for the libquvi library.")
        (uri (string-append "http://serf.googlecode.com/svn/src_releases/serf-"
                            version ".tar.bz2"))
        (sha256
-        (base32 "14155g48gamcv5s0828bzij6vr14nqmbndwq8j8f9g6vcph0nl70"))))
+        (base32 "14155g48gamcv5s0828bzij6vr14nqmbndwq8j8f9g6vcph0nl70"))
+       (patches (map search-patch '("serf-comment-style-fix.patch"
+                                    "serf-deflate-buckets-test-fix.patch")))
+       (patch-flags '("-p0"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("scons" ,scons)
@@ -587,13 +590,6 @@ from streaming URLs.  It is a command-line wrapper for the libquvi library.")
                       (substitute* "SConstruct"
                         (("^env = Environment\\(")
                          "env = Environment(ENV=os.environ, "))))
-         (add-after 'unpack 'remove-non-c89-comment
-                    (lambda _
-                      ;; The SConstruct file asks to compile with -std=c89,
-                      ;; but there is a non-c89 comment in one of the files.
-                      ;; Remove it.
-                      (substitute* "test/test_buckets.c"
-                        (("^//.*") ""))))
          (replace 'build
                   (lambda* (#:key inputs outputs #:allow-other-keys)
                     (let ((out      (assoc-ref outputs "out"))