summary refs log tree commit diff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index da7620cd3d..655367ac33 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
@@ -155,11 +155,10 @@ simulating internal Windows logic like a virtual machine or emulator, Wine
 translates Windows API calls into POSIX calls on-the-fly, eliminating the
 performance and memory penalties of other methods and allowing you to cleanly
 integrate Windows applications into your desktop.")
-    (license license:lgpl2.1+)
-
-    ;; It really only supports IA32, but building on x86_64 will have the same
-    ;; effect as building on i686 anyway.
-    (supported-systems (delete "mips64el-linux" %supported-systems))))
+    ;; Any platform should be able to build wine, but based on '#:system' these
+    ;; are thr ones we currently support.
+    (supported-systems '("i686-linux" "x86_64-linux" "armhf-linux"))
+    (license license:lgpl2.1+)))
 
 (define-public wine64
   (package