summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm36
1 files changed, 33 insertions, 3 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4bf621ee27..7d11a048f2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -28,8 +28,9 @@
 ;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
 ;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019 Noodles! <nnoodle@chiru.no>
+;;; Copyright © 2019 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -331,6 +332,35 @@ i3 uses a plain-text configuration file, and can be extended and controlled from
 many programming languages.")
     (license license:bsd-3)))
 
+(define-public i3-gaps
+  (package (inherit i3-wm)
+           (name "i3-gaps")
+           (version "4.17.1")
+           (source (origin
+                     (method url-fetch)
+                     (uri (string-append
+                           "https://github.com/Airblader/i3/releases/download/"
+                           version "/i3-" version ".tar.bz2"))
+                     (sha256
+                      (base32
+                       "0gqcr6s53dk3f2y9h6cna00rnwnh4yymk96li7lbym3d84cxjzrs"))))
+           (home-page "https://github.com/Airblader/i3")
+           (synopsis "Tiling window manager with gaps")
+           (description "i3-gaps is a fork of i3wm, a tiling window manager
+for X11.  It is kept up to date with upstream, adding a few additional
+features such as gaps between windows.
+
+i3 is a tiling X11 window manager that dynamically manages tiled, stacked,
+and tabbed window layouts.
+
+i3 primarily targets advanced users.  Windows are managed manually and
+organised inside containers, which can be split vertically or horizontally,
+and optionally resized.
+
+i3 uses a plain-text configuration file, and can be extended and controlled
+from many programming languages.")
+           (license license:bsd-3)))
+
 (define-public i3lock
   (package
     (name "i3lock")
@@ -659,14 +689,14 @@ tiled on several screens.")
 (define-public xmobar
   (package
     (name "xmobar")
-    (version "0.31")
+    (version "0.32")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://hackage/package/xmobar/"
                                   "xmobar-" version ".tar.gz"))
               (sha256
                (base32
-                "1sbxva4zaj060bigmxivpn4zlz0q1qbq2np8gljdqkjvysjzpbka"))))
+                "0x2ki3v0pmhl4bva3qi1xx21axayc4sx1nkzhmk2ap4l0cj52jrd"))))
     (build-system haskell-build-system)
     (native-inputs
      `(("ghc-hspec" ,ghc-hspec)