summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 72836ebd6c..1ba80e24ab 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -355,24 +355,25 @@ prompt.")
          "119xvdm4r6irqk0mar80hx6s8ydw26y35h7712rd7nbg7pb7i053"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ;No tests included.
+     `(#:tests? #f                      ; no tests included
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'bootstrap
            (lambda _
-             (zero? (system* "autoreconf" "-vfi")))))))
+             (invoke "autoreconf" "-vfi")
+             #t)))))
     (inputs
-     `(("xcb-util-image" ,xcb-util-image)
-       ("xcb-util" ,xcb-util)
+     `(("cairo" ,cairo)
+       ("libev" ,libev)
        ("libxcb" ,libxcb)
-       ("linux-pam" ,linux-pam)
        ("libxkbcommon" ,libxkbcommon)
-       ("libev" ,libev)
-       ("cairo" ,cairo)))
+       ("linux-pam" ,linux-pam)
+       ("xcb-util" ,xcb-util)
+       ("xcb-util-image" ,xcb-util-image)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("autoconf" ,autoconf)
-        ("automake" ,automake)))
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
     (home-page "https://github.com/PandorasFox/i3lock-color")
     (synopsis "Screen locker with color configuration support")
     (description