summary refs log tree commit diff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index b72567f259..5285037ffe 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -149,6 +149,9 @@ and many other languages.")
     (arguments
      `(#:python ,python-2
        #:tests? #f ; tests fail
+       ;; wxPython directly extends distutils command classes,
+       ;; we can't easily make setup.py use setuptools.
+       #:use-setuptools? #f
        #:configure-flags (list "WXPORT=gtk2"
                                "UNICODE=1")
        #:phases
@@ -181,8 +184,7 @@ and many other languages.")
              #t)))))
     (native-inputs
      `(("mesa" ,mesa) ; for glcanvas
-       ("pkg-config" ,pkg-config)
-       ("python2-setuptools" ,python2-setuptools)))
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("gtk+" ,gtk+-2) ; for wxPython/src/helpers.cpp
        ("wxwidgets" ,wxwidgets-gtk2)))