summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ec5cdbdc28..7149fb65d2 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -498,14 +498,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
 (define-public libxkbcommon
   (package
     (name "libxkbcommon")
-    (version "1.3.0")
+    (version "1.4.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://xkbcommon.org/download/libxkbcommon-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0ysynzzgzd9jdrh1321r4bgw8wd5zljrlyn5y1a31g39xacf02bv"))))
+               "0fbb2dyjvf71p42y2jmwdcylsvj03w52f5rb23c2d00rwahhfg4l"))))
     (build-system meson-build-system)
     (inputs
      (list libx11
@@ -522,13 +522,13 @@ avoiding password prompts when X11 forwarding has already been setup.")
                  (list pkg-config-for-build wayland)
                  '())))
     (arguments
-     `(#:configure-flags
-       (list (string-append "-Dxkb-config-root="
-                            (assoc-ref %build-inputs "xkeyboard-config")
-                            "/share/X11/xkb")
-             (string-append "-Dx-locale-root="
-                            (assoc-ref %build-inputs "libx11")
-                            "/share/X11/locale"))))
+     (list #:configure-flags
+           #~(list (string-append "-Dxkb-config-root="
+                                  (search-input-directory %build-inputs
+                                   "share/X11/xkb"))
+                   (string-append "-Dx-locale-root="
+                                  (search-input-directory %build-inputs
+                                   "share/X11/locale")))))
     (home-page "https://xkbcommon.org/")
     (synopsis "Library to handle keyboard descriptions")
     (description "Xkbcommon is a library to handle keyboard descriptions,
@@ -709,7 +709,7 @@ rasterisation.")
 (define-public libdrm
   (package
     (name "libdrm")
-    (version "2.4.107")
+    (version "2.4.114")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -717,24 +717,24 @@ rasterisation.")
                     version ".tar.xz"))
               (sha256
                (base32
-                "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
+                "09nhk3jx3qzggl5vyii3yh4zm0npjqsbxhzvxrg2xla77a2cyj9h"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags
-       '(,@(match (%current-system)
+     (list #:configure-flags
+           (match (%current-system)
              ((or "armhf-linux" "aarch64-linux")
-              '("-Dexynos=true"
-                "-Domap=true"
-                "-Detnaviv=true"
-                "-Dtegra=true"
-                "-Dfreedreno-kgsl=true"))
-             (_ '())))
-
-       #:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+              #~(list "-Dexynos=true"
+                      "-Domap=true"
+                      "-Detnaviv=true"
+                      "-Dtegra=true"
+                      "-Dfreedreno-kgsl=true"))
+             (_ ''()))
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "meson" "test" "--timeout-multiplier" "5")))))))
     (propagated-inputs
      (list libpciaccess))
     (native-inputs