summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index acc2618e21..77b3f1fbe8 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -618,19 +618,18 @@ to find buttons, etc, on the screen to click on.")
 (define-public xlockmore
   (package
     (name "xlockmore")
-    (version "5.47")
+    (version "5.55")
     (source (origin
              (method url-fetch)
-             (uri (list (string-append
-                          "http://www.tux.org/~bagleyd/xlock/xlockmore-"
-                          version ".tar.xz")
-                        (string-append
-                          "http://www.tux.org/~bagleyd/xlock/xlockmore-old"
-                          "/xlockmore-" version
-                          "/xlockmore-" version ".tar.xz")))
+             (uri (list (string-append "http://sillycycle.com/xlock/"
+                                       name "-" version ".tar.xz")
+                        ;; Previous releases are moved to a subdirectory.
+                        (string-append "http://sillycycle.com/xlock/"
+                                       "recent-releases/"
+                                       name "-" version ".tar.xz")))
              (sha256
               (base32
-               "138d79b8zc2hambbr9fnxp3fhihlcljgqns04zf0kv2f53pavqwl"))))
+               "1y3f76rq2nd10fgi2rx81aj6pijglmm661vjsxi05hpg35dzmwfl"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags (list (string-append "--enable-appdefaultdir="
@@ -642,7 +641,7 @@ to find buttons, etc, on the screen to click on.")
        ("libXext" ,libxext)
        ("libXt" ,libxt)
        ("linux-pam" ,linux-pam)))
-    (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
+    (home-page "http://sillycycle.com/xlockmore.html")
     (synopsis "Screen locker for the X Window System")
     (description
      "XLockMore is a classic screen locker and screen saver for the