summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm53
1 files changed, 46 insertions, 7 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 2cbdeef794..e42c58050d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -38,7 +38,8 @@
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages photo)
-  #:use-module (gnu packages pcre))
+  #:use-module (gnu packages pcre)
+  #:use-module (gnu packages pulseaudio))
 
 (define-public gtk-xfce-engine
   (package
@@ -146,8 +147,9 @@ storage system.")
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
     (propagated-inputs
-     ;; libxfce4kbd-private-2.pc refers to all these.
-     `(("gtk+" ,gtk+-2)
+     `(("gtk+-2" ,gtk+-2)  ; required by libxfce4ui-1.pc
+       ("gtk+-3" ,gtk+)    ; required by libxfce4ui-2.pc
+       ;; libxfce4kbd-private-2.pc refers to all these.
        ("libxfce4util" ,libxfce4util)
        ("xfconf" ,xfconf)))
     (inputs `(("libsm" ,libsm)
@@ -267,6 +269,8 @@ management D-Bus specification.")
                 "1c4p3ckghvsad1sj5v8wmar5mh9cbhail9mmhad2f9pwwb10z4ih"))
               (patches (list (search-patch "xfce4-panel-plugins.patch")))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-gtk3")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
@@ -349,6 +353,37 @@ handle text and images, and has a feature to execute actions on specific text by
 matching them against regular expressions.")
     (license (list gpl2+))))
 
+(define-public xfce4-pulseaudio-plugin
+  (package
+    (name "xfce4-pulseaudio-plugin")
+    (version "0.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  name "/" (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0crvb2gyxbnlf46712arg3m2vqx81dixqhqdwss0bngpijy3ca78"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("exo" ,exo)
+       ("libnotify" ,libnotify)
+       ("libxfce4ui" ,libxfce4ui)
+       ("pulseaudio" ,pulseaudio)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page "http://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/")
+    (synopsis "PulseAudio panel plugin for Xfce")
+    (description
+     "Xfce PulseAudio plugin is a plugin for the Xfce panel which provides a
+convenient way to adjust the audio volume of the PulseAudio sound system and
+to an auto mixer tool like pavucontrol.  It can optionally handle multimedia
+keys for controlling the audio volume.")
+    (license gpl2+)))
+
 (define-public xfce4-appfinder
   (package
     (name "xfce4-appfinder")
@@ -417,7 +452,9 @@ allows you to shutdown the computer from Xfce.")
                                   "/src/" name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "108za1cmjslwzkdl76x9kwxkq8z734kg9nz8rxk057f10pqwxgh4"))))
+                "108za1cmjslwzkdl76x9kwxkq8z734kg9nz8rxk057f10pqwxgh4"))
+              (patches
+               (list (search-patch "xfce4-settings-defaults.patch")))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -631,15 +668,17 @@ on your desktop.")
        ("thunar-volman"        ,thunar-volman)
        ("tumlber"              ,tumbler)
        ("xfce4-appfinder"      ,xfce4-appfinder)
-       ("xfce4-battery-plugin" ,xfce4-battery-plugin)
-       ("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
        ("xfce4-panel"          ,xfce4-panel)
        ("xfce4-session"        ,xfce4-session)
        ("xfce4-settings"       ,xfce4-settings)
        ("xfce4-terminal"       ,xfce4-terminal)
        ("xfconf"               ,xfconf)
        ("xfdesktop"            ,xfdesktop)
-       ("xfwm4"                ,xfwm4)))
+       ("xfwm4"                ,xfwm4)
+       ;; Panel plugins.
+       ("xfce4-battery-plugin"    ,xfce4-battery-plugin)
+       ("xfce4-clipman-plugin"    ,xfce4-clipman-plugin)
+       ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)))
     (home-page "http://www.xfce.org/")
     (synopsis "Desktop environment (meta-package)")
     (description