summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 914012625f..a4987c1b2e 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -111,6 +111,8 @@ Xfce Desktop Environment.")
           ;; Run test-suite under a dbus session.
           (setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
                   (string-append %output "/share"))
+          ;; For the missing '/etc/machine-id'.
+          (setenv "DBUS_FATAL_WARNINGS" "0");
           (zero? (system* "dbus-launch" "make" "check")))
         (alist-delete 'check %standard-phases))))
     (native-inputs