summary refs log tree commit diff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 0e8cb5fafc..2de9074f28 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -80,7 +81,8 @@ periodic timestamps for seeking.")
               "1gby6hapz9njx4l9g0pndyk4q83z5fgrgc30mfwfgx7bllspsk43"))))
    (build-system gnu-build-system)
    (propagated-inputs `(("libogg" ,libogg)))
-   (arguments `(#:configure-flags '("LDFLAGS=-lm")))
+   (arguments `(#:configure-flags '("LDFLAGS=-lm")
+                #:parallel-tests? #f))
    (synopsis "libvorbis, a library implementing the vorbis audio format")
    (description
     "The libvorbis library implements the ogg vorbis audio format,
@@ -201,7 +203,12 @@ OpenBSD's sndio.")
              (list (search-patch "flac-fix-memcmp-not-declared.patch")))))
    (build-system gnu-build-system)
    (arguments
-    `(#:parallel-tests? #f))
+    `(#:parallel-tests? #f
+      ;; By default, man pages are put in PREFIX/man,
+      ;; but we want them in PREFIX/share/man.
+      #:configure-flags (list (string-append "--mandir="
+                                             (assoc-ref %outputs "out")
+                                             "/share/man"))))
    ;; FIXME: configure also looks for xmms, input could be added once it exists
    (inputs `(("libogg" ,libogg)))
    (synopsis "flac free lossless audio codec")