summary refs log tree commit diff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 49d23bf6d5..15502bd0e9 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -235,7 +235,6 @@ It currently supports:
 (define flac
   (package
    (name "flac")
-   (replacement flac/fixed)
    (version "1.3.2")
    (source (origin
             (method url-fetch)
@@ -243,7 +242,8 @@ It currently supports:
                                 version ".tar.xz"))
             (sha256
              (base32
-              "0gymm2j3276kr9nz6vmgfwsdfrq6c449n40a0mzz8h6wc7nw7kwi"))))
+              "0gymm2j3276kr9nz6vmgfwsdfrq6c449n40a0mzz8h6wc7nw7kwi"))
+            (patches (search-patches "flac-CVE-2017-6888.patch"))))
    (build-system gnu-build-system)
    (arguments
     `(#:parallel-tests? #f))
@@ -257,14 +257,6 @@ meaning that audio is compressed in FLAC without any loss in quality.")
                                "See COPYING in the distribution.")) ; and LGPL and GPL
    (home-page "https://xiph.org/flac/")))
 
-(define flac/fixed
-  (package
-    (inherit flac)
-    (source
-      (origin
-        (inherit (package-source flac))
-        (patches (search-patches "flac-CVE-2017-6888.patch"))))))
-
 (define libkate
   (package
    (name "libkate")