summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index f1d1342d5d..770bac3670 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1153,14 +1153,14 @@ XSL-T processor.  It also performs any necessary post-processing.")
 (define-public xmlsec
   (package
     (name "xmlsec")
-    (version "1.2.32")
+    (version "1.2.36")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.aleksey.com/xmlsec/download/"
                                   "xmlsec1-" version ".tar.gz"))
               (sha256
                (base32
-                "0hy0nwz57n9r5wwab9xa66gzwlwvzs54nhlfn3jh8q13acl710z3"))))
+                "100wsklff8x30rsg0xp191kg8p3z5va2d0q3iy08a791ic07xngh"))))
     (build-system gnu-build-system)
     (propagated-inputs                  ; according to xmlsec1.pc
      (list libxml2 libxslt))
@@ -1175,6 +1175,8 @@ XSL-T processor.  It also performs any necessary post-processing.")
 supports XML security standards such as XML Signature, XML Encryption,
 Canonical XML (part of Libxml2) and Exclusive Canonical XML (part of
 Libxml2).")
+    (properties
+     '((upstream-name . "xmlsec1")))
     (license (license:x11-style "file://COPYING"
                                 "See 'COPYING' in the distribution."))))
 
@@ -1182,12 +1184,10 @@ Libxml2).")
   (package/inherit xmlsec
     (name "xmlsec-nss")
     (native-inputs
-     ;; For tests.
-     `(("nss:bin" ,nss "bin")           ; for certutil
-       ,@(package-native-inputs xmlsec)))
+     (modify-inputs (package-native-inputs xmlsec)
+       (prepend `(,nss "bin"))))        ;certutil, for tests
     (inputs
-     `(("nss" ,nss)
-       ("libltdl" ,libltdl)))
+     (list nss libltdl))
     (arguments
      ;; NSS no longer supports MD5 since 3.59, don't attempt to use it.
      '(#:configure-flags '("--disable-md5")))
@@ -1197,8 +1197,7 @@ Libxml2).")
   (package/inherit xmlsec
     (name "xmlsec-openssl")
     (inputs
-     `(("openssl" ,openssl)
-       ("libltdl" ,libltdl)))
+     (list openssl libltdl))
     (synopsis "XML Security Library (using OpenSSL instead of GnuTLS)")))
 
 (define-public minixml