summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index e09fde733f..19391ea8aa 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1096,16 +1096,16 @@ C++ programming language.")
     (version "4.0.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/leethomason/tinyxml2/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/leethomason/tinyxml2.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "083z4r4khcndxi9k840lcr48sqxvar4gpsnf749xfdn1bkr8xcql"))))
+        (base32 "1a0skfi8rzk53qcxbv88qlvhlqzvsvg4hm20dnx4zw7vrn6anr9y"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))    ; no tests
+     `(#:tests? #f))                    ; no tests
     (synopsis "Small XML parser for C++")
     (description "TinyXML2 is a small and simple XML parsing library for the
 C++ programming language.")