summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 30f30535d0..28d11efdae 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -56,6 +56,7 @@
   (package
     (name "expat")
     (version "2.2.1")
+    (replacement expat-2.2.2)
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/expat/expat/"
@@ -72,6 +73,18 @@ stream-oriented parser in which an application registers handlers for
 things the parser might find in the XML document (like start tags).")
     (license license:expat)))
 
+(define expat-2.2.2  ; Fixes CVE-2017-9233, CVE-2016-9063 and other issues.
+  (package
+    (inherit expat)
+    (version "2.2.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/expat/expat/"
+                                 version "/expat-" version ".tar.bz2"))
+             (sha256
+              (base32
+               "0ik0r39ala9c6hj4kxrk933klgwkzlkbrfhvhaykx8l1rwgr2xj3"))))))
+
 (define-public libebml
   (package
     (name "libebml")