summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9f83c7d079..b89115a051 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1553,11 +1553,14 @@ Excel(TM) since version 2007.")
     (arguments
      `(#:build-target "build"
        #:test-target "test"
-       ;; This test sometimes fails with an out of memory exception
-       #:test-exclude (list "**/NoAnnotationsRequiredTest.java")
        #:phases
        (modify-phases %standard-phases
-         (replace 'install (install-jars "jar")))))
+         (replace 'install (install-jars "jar"))
+         (add-before 'check 'disable-failing-test
+           (lambda _
+             ;; This test sometimes fails with an out of memory exception
+             (delete-file
+              "test/src/org/simpleframework/xml/core/NoAnnotationsRequiredTest.java"))))))
     (native-inputs
      (list unzip))
     (home-page "http://simple.sourceforge.net/")