summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm50
1 files changed, 46 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b39bbd436f..42422a3c56 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1128,7 +1129,7 @@ themselves.")
 (define-public libpciaccess
   (package
     (name "libpciaccess")
-    (version "0.13.2")
+    (version "0.13.4")
     (source
       (origin
         (method url-fetch)
@@ -1138,7 +1139,7 @@ themselves.")
                ".tar.bz2"))
         (sha256
           (base32
-            "06fy43n3c450h7xqpn3094bnfn7ca1mrq3i856y8kyqa0lmqraxb"))))
+            "1krgryi9ngjr66242v0v5mczihgv0y7rrvx0563arr318mjn9y07"))))
     (build-system gnu-build-system)
     (inputs
       `(("zlib" ,zlib)))
@@ -2709,8 +2710,8 @@ framebuffer device.")
            "19y13xl7yfrgyis92rmxi0ld95ajgr5il0n9j1dridwzw9aizz1q"))
         (patches (list (search-patch "xf86-video-geode-glibc-2.20.patch")))))
     (build-system gnu-build-system)
-    (inputs `(("pkg-config" ,pkg-config)
-              ("xorg-server" ,xorg-server)))
+    (inputs `(("xorg-server" ,xorg-server)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
     (supported-systems
      ;; This driver is only supported on i686 systems.
      (filter (lambda (system) (string-prefix? "i686-" system))
@@ -5439,3 +5440,44 @@ perl programs to display windows and graphics on X11 servers.")
     ;; of the extension modules in the directory Protocol/Ext: see those files
     ;; for details)."
     (license (package-license perl))))
+
+(define-public xcompmgr
+  (package
+    (name "xcompmgr")
+    (version "1.1.7")
+    (source
+     (origin
+       ;; there's no current tarball
+       (method git-fetch)
+       (uri (git-reference
+             (url "http://anongit.freedesktop.org/git/xorg/app/xcompmgr.git")
+             (commit (string-append name "-" version))))
+       (sha256
+        (base32
+         "04swkrm3gk689wrjc418bd3n25w8r20kg1xfbn5j8d7mx1r5gf16"))
+       (file-name (string-append name "-" version))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'autogen
+                              (lambda _
+                                (setenv "NOCONFIGURE" "t")
+                                (zero? (system* "sh" "autogen.sh")))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)))
+    (inputs
+     `(("libX11" ,libx11)
+       ("libXext" ,libxext)
+       ("libXcomposite" ,libxcomposite)
+       ("libXfixes" ,libxfixes)
+       ("libXdamage" ,libxdamage)
+       ("libXrender" ,libxrender)))
+    (synopsis "X Compositing manager using RENDER")
+    (description "xcompmgr is a sample compositing manager for X servers
+supporting the XFIXES, DAMAGE, RENDER, and COMPOSITE extensions.  It enables
+basic eye-candy effects.")
+    (home-page "http://cgit.freedesktop.org/xorg/app/xcompmgr/")
+    (license (license:x11-style
+              "http://cgit.freedesktop.org/xorg/app/xcompmgr/tree/COPYING"))))