summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index cde6475a09..c1b3ee4c35 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -384,6 +384,11 @@ tracking.")
         ("font-util", font-util)
         ("mkfontdir" ,mkfontdir)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        ;; install fonts into subdirectory of package output instead of
+        ;; font-util-?.?.?/share/fonts/X11
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -410,6 +415,9 @@ tracking.")
         ("font-util", font-util)
         ("mkfontdir" ,mkfontdir)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -1004,6 +1012,9 @@ tracking.")
         ("font-util" ,font-util)
         ("bdftopcf" ,bdftopcf)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -1055,6 +1066,9 @@ tracking.")
         ("font-util" ,font-util)
         ("bdftopcf" ,bdftopcf)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")