summary refs log tree commit diff
path: root/gnu/packages/zile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/zile.scm')
-rw-r--r--gnu/packages/zile.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index f1c03fb64c..13a5440eea 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,25 +33,26 @@
 (define-public zile
   (package
     (name "zile")
-    (version "2.4.11")
+    (version "2.4.13")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/zile/zile-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1k593y1xzvlj52q0gyhcx2lllws4sg84b8r9pcginjb1vjypplhz"))))
+               "03mcg0bxkzprlsx8y6h22w924pzx4a9zr7zm3g11j8j3x9lz75f7"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-before
-                 'configure 'patch-/bin/sh
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   (let ((bash (assoc-ref inputs "bash")))
-                     ;; Refer to the actual shell.
-                     (substitute* '("lib/spawni.c" "src/funcs.c")
-                       (("/bin/sh")
-                        (string-append bash "/bin/sh")))))
-                 %standard-phases)))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-/bin/sh
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((bash (assoc-ref inputs "bash")))
+               ;; Refer to the actual shell.
+               (substitute* '("lib/spawni.c" "src/funcs.c")
+                 (("/bin/sh")
+                  (string-append bash "/bin/sh")))
+               #t))))))
     (inputs
      `(("boehm-gc" ,libgc)
        ("ncurses" ,ncurses)
@@ -59,7 +61,7 @@
      `(("perl" ,perl)
        ("help2man" ,help2man)
        ("pkg-config" ,pkg-config)))
-    (home-page "http://www.gnu.org/software/zile/")
+    (home-page "https://www.gnu.org/software/zile/")
     (synopsis "Lightweight Emacs clone")
     (description
      "GNU Zile is a lightweight Emacs clone.  It usage is similar to the