summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 92aebf2089..92c247ca38 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3392,22 +3392,30 @@ filters, new key bindings and faces.  It can be enabled by
     (build-system emacs-build-system)
     (inputs (list djview djvulibre))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((file "djvu.el")
-                   (djview (assoc-ref inputs "djview"))
-                   (djvulibre (assoc-ref inputs "djvulibre")))
-               ;; Specify the absolute executable locations.
-               (chmod file #o644)
-               (substitute* file
-                 (("\"djvused\"") (string-append "\"" djvulibre "/bin/djvused\""))
-                 (("\"djvm\"") (string-append "\"" djvulibre "/bin/djvm\""))
-                 (("\"ddjvu\"") (string-append "\"" djvulibre "/bin/ddjvu\"")))
-               (emacs-substitute-variables file
-                 ("djvu-djview-command" (string-append djview "/bin/djview"))))
-             #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'configure
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((file "djvu.el"))
+                ;; Specify the absolute executable locations.
+                (make-file-writable file)
+                (substitute* file
+                  (("\"djvused\"")
+                   (string-append "\""
+                                  (search-input-file inputs "/bin/djvused")
+                                  "\""))
+                  (("\"djvm\"")
+                   (string-append "\""
+                                  (search-input-file inputs "/bin/djvm")
+                                  "\""))
+                  (("\"ddjvu\"")
+                   (string-append "\""
+                                  (search-input-file inputs "/bin/ddjvu")
+                                  "\"")))
+                (emacs-substitute-variables file
+                  ("djvu-djview-command"
+                   (search-input-file inputs "/bin/djview")))))))))
     (home-page "http://elpa.gnu.org/packages/djvu.html")
     (synopsis "Edit and view Djvu files via djvused")
     (description