summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm16
-rw-r--r--gnu/packages/ipfs.scm2
-rw-r--r--gnu/packages/mail.scm2
3 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fbe5921e25..66ec8ae39f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4470,9 +4470,9 @@ well as a program to generate applications and command files.")
       (home-page "https://github.com/stathat/go")
       (license license:expat))))
 
-(define-public go-github-com-syndtr-goleveldb-leveldb
+(define-public go-github-com-syndtr-goleveldb
   (package
-    (name "go-github-com-syndtr-goleveldb-leveldb")
+    (name "go-github-com-syndtr-goleveldb")
     (version "1.0.0")
     (source
      (origin
@@ -4487,8 +4487,16 @@ well as a program to generate applications and command files.")
     (arguments
      (list
       #:go go-1.21
-      #:import-path "github.com/syndtr/goleveldb/leveldb"
-      #:unpack-path "github.com/syndtr/goleveldb"))
+      #:import-path "github.com/syndtr/goleveldb"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Replace when go-build-system supports nested path.
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key import-path tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
     (propagated-inputs
      (list go-github-com-onsi-gomega
            go-github-com-onsi-ginkgo
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index d75a99c4e1..bdfa88bd94 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -736,7 +736,7 @@ written in Go.")
                   go-github-com-pkg-errors
                   go-github-com-prometheus-client-golang
                   go-github-com-stretchr-testify
-                  go-github-com-syndtr-goleveldb-leveldb
+                  go-github-com-syndtr-goleveldb
                   go-github-com-tidwall-sjson
                   go-github-com-whyrusleeping-go-sysinfo
                   ;;go-github-com-whyrusleeping-multiaddr-filter
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6aacdcb73c..1bf4debe68 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -5097,7 +5097,7 @@ remote SMTP server.")
              go-github-com-creack-pty
              go-github-com-arran4-golang-ical
              go-github-com-protonmail-go-crypto
-             go-github-com-syndtr-goleveldb-leveldb
+             go-github-com-syndtr-goleveldb
              go-git-sr-ht-sircmpwn-getopt
              go-git-sr-ht-rockorager-tcell-term
              python