summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a184d1ad6..12fcb8e83e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12657,14 +12657,13 @@ Jupyter kernels such as IJulia and IRKernel.")
 (define-public python-qtconsole
   (package
     (name "python-qtconsole")
-    (version "4.4.3")
+    (version "4.7.7")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "qtconsole" version))
        (sha256
-        (base32
-         "1b03n1ixzscm0jw97l4dq5iy4fslnqxq5bb8287xb7n2a1gs26xw"))))
+        (base32 "013qgpsm8jzcz3prhq7sxs36l8f7fgagmn3xa010gfhxf7cfldpj"))))
     (build-system python-build-system)
     (arguments
      ;; XXX: Tests are disabled, because this package needs python-ipython 7,
@@ -12677,10 +12676,11 @@ Jupyter kernels such as IJulia and IRKernel.")
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
            (lambda _
-             (setenv "QT_QPA_PLATFORM" "offscreen")
-             #t)))))
+             (setenv "QT_QPA_PLATFORM" "offscreen"))))))
     (propagated-inputs
-     (list python-ipykernel python-ipython python-pyqt))
+     (list python-ipykernel python-ipython-genutils python-jupyter-client
+           python-jupyter-core python-pygments python-pyqt python-pyzmq
+           python-qtpy python-traitlets))
     (native-inputs
      (list python-pytest))
     (home-page "https://jupyter.org")