summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/graph.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index f178e00312..c9486935ae 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -563,23 +563,23 @@ transformed into common image formats for display or printing.")
                                      "python"))))
                             "/site-packages/"))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("gcc-10" ,gcc-10)
-       ("ncurses" ,ncurses)))
+     `(("gcc-10" ,gcc-10)
+       ("ncurses" ,ncurses)
+       ("pkg-config" ,pkg-config)))
     (inputs
-     `(("python" ,python-wrapper)
-       ("boost" ,boost)
+     `(("boost" ,boost)
+       ("cairomm" ,cairomm)
+       ("cgal" ,cgal)
        ("expat" ,expat)
        ("gmp" ,gmp)
-       ("cgal" ,cgal)
-       ("sparsehash" ,sparsehash)
        ("gtk+" ,gtk+)
-       ("cairomm" ,cairomm)))
+       ("python" ,python-wrapper)
+       ("sparsehash" ,sparsehash)))
     (propagated-inputs
-     `(("python-scipy" ,python-scipy)
+     `(("python-matplotlib" ,python-matplotlib)
        ("python-numpy" ,python-numpy)
        ("python-pycairo" ,python-pycairo)
-       ("python-matplotlib" ,python-matplotlib)))
+       ("python-scipy" ,python-scipy)))
     (synopsis "Manipulate and analyze graphs with Python efficiently")
     (description "Graph-tool is an efficient Python module for manipulation
 and statistical analysis of graphs (a.k.a. networks).  Contrary to most other