summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8d25614e3a..972a391a29 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -391,6 +391,13 @@ without requiring the source code to be rewritten.")
                             (("^GUILE_OPTIMIZATIONS.*")
                              "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
                    #~())
+            #$@(if (target-ppc64le?)
+                   #~((add-after 'unpack 'skip-oom-test
+                        (lambda _
+                          ;; This test hangs with guile-3.0.9 and libgc-8.2.2.
+                          (substitute* "test-suite/standalone/test-out-of-memory"
+                            (("!#") "!#\n\n(exit 77)\n")))))
+                   #~())
             #$@(if (or (target-ppc32?)
                        (target-riscv64?))
                    #~((add-after 'unpack 'skip-failing-fdes-test