summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xdisorg.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2bb740ce8d..5b9c50d8bd 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -519,12 +519,9 @@ avoiding password prompts when X11 forwarding has already been setup.")
            wayland-protocols
            xkeyboard-config))
     (native-inputs
-     (append (list bison doxygen pkg-config python)
-             (if (%current-target-system)
-                 ;; wayland-scanner is required at build time.
-                 ;; TODO: Remove this conditional on core-updates.
-                 (list pkg-config-for-build wayland)
-                 '())))
+     (list bison doxygen pkg-config python
+           ;; wayland-scanner is required at build time.
+           wayland))
     (arguments
      (list #:configure-flags
            #~(list (string-append "-Dxkb-config-root="