summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 056775ec40..d01c1d3df1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6345,7 +6345,13 @@ security policies on Python objects.")
     (license zpl2.1)))
 
 (define-public python2-zope-security
-  (package-with-python2 python-zope-security))
+  (let ((zope-security (package-with-python2 python-zope-security)))
+    (package (inherit zope-security)
+      (propagated-inputs
+       `(("python2-zope-testrunner" ,python2-zope-testrunner)
+         ,@(alist-delete
+            "python-zope-testrunner"
+            (package-propagated-inputs zope-security)))))))
 
 (define-public python-zope-component
   (package