summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/jupyter.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 175c12496a..18efc9bb8b 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -339,6 +339,39 @@ endpoints—to Jupyter web applications.")
 are interactive HTML widgets for Jupyter notebooks and the IPython kernel.")
     (license license:bsd-3)))
 
+(define-public python-jupyter-server-mathjax
+  (package
+    (name "python-jupyter-server-mathjax")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jupyter_server_mathjax" version))
+       (sha256
+        (base32 "1cz7grhj9jih9mgw4xk7a4bqy1fwlb1jsawh6ykxnvpydn76rnb4"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion "/tmp"
+                  (invoke "pytest" "-vv"
+                          "--pyargs" "jupyter_server_mathjax"))))))))
+    (propagated-inputs (list python-jupyter-server))
+    (native-inputs
+     (list python-jupyter-server
+           python-jupyter-packaging
+           python-pytest
+           python-pytest-tornasync))
+    (home-page "https://jupyter.org")
+    (synopsis "Jupyter Server extension for serving Mathjax")
+    (description "This package provides a Jupyter Server extension for serving
+Mathjax, the JavaScript display engine for mathematics.")
+    (license license:bsd-3)))
+
 (define-public python-nbclient
   (package
     (name "python-nbclient")