summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b92a8258aa..68a2dff47a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -175,6 +175,37 @@ automatically pruning objects to maintain the constraints.")
 visualization of their differences.")
     (license license:gpl2+)))
 
+(define-public r-googledrive
+  (package
+    (name "r-googledrive")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "googledrive" version))
+       (sha256
+        (base32
+         "0qbyl0wyrxmwn9jg0d2s7c1kmmvmx61qbyx3qby4js8dks70f1ls"))))
+    (properties `((upstream-name . "googledrive")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-curl" ,r-curl)
+       ("r-gargle" ,r-gargle)
+       ("r-glue" ,r-glue)
+       ("r-httr" ,r-httr)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-magrittr" ,r-magrittr)
+       ("r-purrr" ,r-purrr)
+       ("r-rlang" ,r-rlang)
+       ("r-tibble" ,r-tibble)
+       ("r-uuid" ,r-uuid)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://googledrive.tidyverse.org")
+    (synopsis "Interface to Google Drive")
+    (description "This package lets you manage Google Drive files from R.")
+    (license license:expat)))
+
 (define-public r-waldo
   (package
     (name "r-waldo")