summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bittorrent.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 1c9358b896..bc0364d87c 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -105,6 +105,11 @@
        #:glib-or-gtk-wrap-excluded-outputs '("out")
        #:phases
        (modify-phases %standard-phases
+         ;; Avoid embedding kernel version for reproducible build
+         (add-after 'unpack 'remove-kernel-version
+           (lambda _
+             (substitute* "third-party/miniupnpc/updateminiupnpcstrings.sh"
+               (("OS_VERSION=`uname -r`") "OS_VERSION=Guix"))))
          (add-after 'install 'move-gui
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Move the GUI to its own output, so that "out" doesn't