summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 57a07b9226..466be1dbc2 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -295,12 +295,17 @@ Android, and ChromeOS.")
           "-Dgtk_doc=enabled")
          #:phases
          (modify-phases %standard-phases
-           (add-after 'unpack 'disable-failing-test
+           (add-after 'unpack 'disable-failing-tests
              (lambda _
                (substitute* "tests/meson.build"
                  ;; ‘test-set-port-range.c:66:main: assertion failed:
                  ;; (nice_agent_gather_candidates (agent, stream1))’
                  (("'test-set-port-range'" all)
+                  (string-append "# " all))
+                 ;; The following test is disabled as it fails in a
+                 ;; nondeterministic fashion (see:
+                 ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/151).
+                 (("'test-bsd'" all)
                   (string-append "# " all)))
                (substitute* "stun/tests/meson.build"
                  ;; test-bind.c:234: bad_responses: Assertion `len >= 20'