summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 37c67b8788..2427d35ea1 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -298,7 +298,7 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
      `(#:phases
        (modify-phases %standard-phases
          (delete 'check)
-         (add-after 'install 'check ;; add-after 'install
+         (add-after 'install 'check
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
@@ -308,9 +308,8 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
                (setenv "XDG_DATA_DIRS"
                        (string-append out "/share:"
                                       (getenv "XDG_DATA_DIRS")))
-               (zero?
-                (system* "ctest" "-R" ;; almost all tests require a display
-                         "filteringstrategy|kdevvarlengtharray|kdevhash"))))))))
+               (invoke "ctest" "-R" ; almost all tests require a display
+                       "filteringstrategy|kdevvarlengtharray|kdevhash")))))))
     (home-page "https://github.com/KDE/kdevplatform")
     (synopsis "Framework to build integrated development environments (IDEs)")
     (description "KDevPlatform is the basis of KDevelop and contains some