summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/slang.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/slang.scm b/gnu/packages/slang.scm
index 404a4535ca..e3c9134d60 100644
--- a/gnu/packages/slang.scm
+++ b/gnu/packages/slang.scm
@@ -57,14 +57,21 @@
        #:parallel-build? #f  ; there's at least one race
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'reduce-array-test-size
+           ;; Reduce the size of the array, otherwise the array.sl/array.slc
+           ;; tests fails with "Unable to create a multi-dimensional array of
+           ;; the desired size" on 32 bit systems.
+           (lambda _
+             (substitute* "src/test/array.sl"
+               (("10000,10000,10000,10000,10000,10000")
+                "100,100,100,100,100,100"))))
          (add-before 'configure 'substitute-before-config
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((ncurses (assoc-ref inputs "ncurses")))
                (substitute* "configure"
                  (("MISC_TERMINFO_DIRS=\"\"")
                   (string-append "MISC_TERMINFO_DIRS="
-                                 "\"" ncurses "/share/terminfo" "\"")))
-               #t))))))
+                                 "\"" ncurses "/share/terminfo" "\"")))))))))
     (inputs
      `(("readline" ,readline)
        ("zlib" ,zlib)