summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/protobuf.scm2
-rw-r--r--gnu/packages/python-xyz.scm15
2 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 82cf8f452d..112b9b1fb1 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -354,7 +354,7 @@ any memory-restricted system.")
      (list python-grpc-stubs
            python-grpcio-tools
            python-pytest
-           python-typing-extensions-next))
+           python-typing-extensions))
     (propagated-inputs
      (list protobuf
            python-protobuf
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc3b27d22b..ad90e2f3e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22683,21 +22683,6 @@ Included are implementations of:
 @end enumerate\n")
     (license license:psfl)))
 
-(define-public python-typing-extensions-next
-  (package
-    (inherit python-typing-extensions)
-    (name "python-typing-extensions")
-    (version "4.2.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/python/typing")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1bbry1rg7q5ppkgzdk4nwl7q1w8bbhajm4q68wb9dm6rf7hg1023"))))))
-
 (define-public bpython
   (package
     (name "bpython")