summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index e3e874dac2..e4aacdc072 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -157,10 +157,7 @@ atlas_libs = openblas
                                       (tgt-dir (string-append html "/" dir)))
                                  (install-file file html)))
                              (find-files ".")))))))
-         ;; Tests can only be run after the library has been installed and not
-         ;; within the source directory.
-         (delete 'check)
-         (add-after 'install 'check
+         (replace 'check
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?
                (add-installed-pythonpath inputs outputs)