summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/module-init-tools-moduledir.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/patches/module-init-tools-moduledir.patch b/gnu/packages/patches/module-init-tools-moduledir.patch
index 7a40a03b04..08f03d1cc4 100644
--- a/gnu/packages/patches/module-init-tools-moduledir.patch
+++ b/gnu/packages/patches/module-init-tools-moduledir.patch
@@ -6,7 +6,7 @@ Original patch by David Guibert, from Nixpkgs; adjusted to use
 'LINUX_MODULE_DIRECTORY' rather than 'MODULE_DIR' as the variable name.
 
 diff --git a/depmod.c b/depmod.c
-index a1d2f8c..a8f92b2 100644
+index a1d2f8c..ff579c7 100644
 --- a/depmod.c
 +++ b/depmod.c
 @@ -48,9 +48,6 @@
@@ -77,7 +77,7 @@ index a1d2f8c..a8f92b2 100644
 +                module_dir = "/lib/modules";
 +        }
 +
-+	nofail_asprintf(&dirname, "%s%s%s", basedir, module_dir, version);
++	nofail_asprintf(&dirname, "%s%s/%s", basedir, module_dir, version);
  
  	if (maybe_all) {
  		if (!doing_stdout && !depfile_out_of_date(dirname))