summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 43506a7bc2..2695530fee 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -128,11 +128,16 @@ programs for the manipulation and analysis of astronomical data.")
                "04avigz8i8mi2x6x71bqr9np85n1p9qnvbj2hxr947f1jv22zr8g"))))
     (build-system cmake-build-system)
     (inputs
-     `(("qt"   ,qt)
+     `(("qtbase" ,qtbase)
+       ("qtmultimedia" ,qtmultimedia)
+       ("qtscript" ,qtscript)
+       ("qtserialport" ,qtserialport)
        ("zlib" ,zlib)))
     (native-inputs
      `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
-       ("perl" ,perl))) ; For pod2man
+       ("perl" ,perl) ; For pod2man
+       ("qtbase" ,qtbase) ; Qt MOC is needed at compile time
+       ("qttools" ,qttools)))
     (arguments
       `(#:test-target "tests"
         #:phases (modify-phases %standard-phases