summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-pillow-fix-failing-tests.patchbin0 -> 112373 bytes
-rw-r--r--gnu/packages/python.scm4
2 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/patches/python-pillow-fix-failing-tests.patch b/gnu/packages/patches/python-pillow-fix-failing-tests.patch
new file mode 100644
index 0000000000..2575d6f612
--- /dev/null
+++ b/gnu/packages/patches/python-pillow-fix-failing-tests.patch
Binary files differdiff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7ff1e78bbe..ce3aa299bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3739,7 +3739,9 @@ the OleFileIO module from PIL, the Python Image Library.")
        (uri (pypi-uri "Pillow" version))
        (sha256
         (base32
-         "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))))
+         "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))
+       (patch-flags '("-p1" "--binary"))
+       (patches (search-patches "python-pillow-fix-failing-tests.patch"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-nose"       ,python-nose)))