summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/patches/gnome-music-fix-crash.patch36
2 files changed, 40 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 00b36bbf45..fb0d9c3358 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -842,12 +842,14 @@ cloud integration is offered through GNOME Online Accounts.")
                        (version-major+minor version) "/"
                        name "-" version ".tar.xz"))
        (sha256
-        (base32 "0zdpjgwf48bqb66wrl6k33pzcmc2g3m1046ma7z8xaj9idpi37jh"))))
+        (base32 "0zdpjgwf48bqb66wrl6k33pzcmc2g3m1046ma7z8xaj9idpi37jh"))
+       (patches
+        (search-patches "gnome-music-fix-crash.patch"))))
     (build-system meson-build-system)
     (outputs '("out" "help"))
     (arguments
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
-       #:python? #t ; To wrap binaries
+       #:python? #t          ; To wrap binaries
        #:tests? #f           ; Tests require networking
        #:phases
        (modify-phases %standard-phases
diff --git a/gnu/packages/patches/gnome-music-fix-crash.patch b/gnu/packages/patches/gnome-music-fix-crash.patch
new file mode 100644
index 0000000000..be154a7cb3
--- /dev/null
+++ b/gnu/packages/patches/gnome-music-fix-crash.patch
@@ -0,0 +1,36 @@
+From 8e12c01e99fcc1bf706097ee64b2719fb2d87202 Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@debian.org>
+Date: Sun, 30 Aug 2020 15:17:33 +0100
+Subject: [PATCH] scrobbler: Don't crash if gnome-online-accounts is
+ unavailable
+
+goa_client_get_manager() can return NULL (in Python,
+GoaClient.get_manager() can return None) if the gnome-online-accounts
+D-Bus service is not available.
+
+Resolves: gnome-music#410
+Bug-Debian: https://bugs.debian.org/969271
+Signed-off-by: Simon McVittie <smcv@debian.org>
+---
+ gnomemusic/scrobbler.py | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/gnomemusic/scrobbler.py b/gnomemusic/scrobbler.py
+index 04888594..d133f2fa 100644
+--- a/gnomemusic/scrobbler.py
++++ b/gnomemusic/scrobbler.py
+@@ -76,6 +76,11 @@ class GoaLastFM(GObject.GObject):
+             return
+ 
+         manager = self._client.get_manager()
++
++        if manager is None:
++            self._log.info("GNOME Online Accounts is unavailable")
++            return
++
+         try:
+             manager.call_is_supported_provider(
+                 "lastfm", None, self._lastfm_is_supported_cb)
+-- 
+GitLab
+