summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dav.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 835b8fcf39..a06878dc92 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -73,11 +73,8 @@ clients.")
          ;; vdirsyncer requires itself to be installed in order to build
          ;; the manpage.
          (add-after 'install 'manpage
-           (lambda* (#:key outputs #:allow-other-keys)
-             (setenv "PYTHONPATH"
-                     (string-append
-                       (getenv "PYTHONPATH")
-                       ":" (assoc-ref outputs "out")))
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
              (zero? (system* "make" "--directory=docs/" "man"))
              (install-file
                "docs/_build/man/vdirsyncer.1"