summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/autotools.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 1f18ebc1ca..47355d622b 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -72,10 +72,9 @@ can use, in the form of M4 macro calls.")
     (name (string-append (package-name autoconf) "-wrapper"))
     (build-system trivial-build-system)
     (inputs `(("guile"
-               ,(lambda _
-                  ;; XXX: Kludge to hide the circular dependency.
-                  (module-ref (resolve-interface '(gnu packages guile))
-                              'guile-2.0)))
+               ;; XXX: Kludge to hide the circular dependency.
+               ,(module-ref (resolve-interface '(gnu packages guile))
+                            'guile-2.0))
               ("autoconf" ,autoconf)
               ("bash" ,bash)))
     (arguments